Mopolauta

Elasto Mania board
It is currently 16 Aug 2017, 16:27

All times are UTC [ DST ]




Post new topic Reply to topic  [ 11 posts ] 
Author Message
 Post subject: Kopasite Problem
PostPosted: 11 Mar 2013, 23:19 
Offline
Kuski
User avatar

Joined: 5 Apr 2007, 12:30
Posts: 1157
Location: Norway, Sandnes
I can't access kopasite. Got this message:
Kopasite wrote:
Could not connect: Too many connections


Edit: Works again :)

_________________
TT:39.59.86|| AvgTT:41.49.24 || Multi TT:27:43:82 || Team [TR]


Top
 Profile  
 
 Post subject: Re: Kopasite Problem
PostPosted: 15 Aug 2015, 21:54 
Offline
Kuski
User avatar

Joined: 5 Apr 2007, 12:30
Posts: 1157
Location: Norway, Sandnes
There is this one bug thats always been around. Sometimes Kopasite register rec with 0.01s difference from actual time, and then it can't be verified to eol.

_________________
TT:39.59.86|| AvgTT:41.49.24 || Multi TT:27:43:82 || Team [TR]


Top
 Profile  
 
 Post subject: Re: Kopasite Problem
PostPosted: 15 Aug 2015, 22:21 
Offline
Kuski
User avatar

Joined: 23 May 2002, 13:59
Posts: 6293
Location: In a northern danish city beating YOUR record.
Yea it's a bug in the script that reads time from rec file that I didn't code, no idea if it would be possible to fix that. But have thought of making it so it allows a difference of 0.01 and then takes the time from EOL.

_________________
Kopasite ^ 39 level packs and 1193 levels for your höyling pleasure
LaMe world of Kopa ^ Team LaMe
Elma Online ^ Moposite Records ^ Upload


Top
 Profile  
 
 Post subject: Re: Kopasite Problem
PostPosted: 17 Aug 2015, 03:55 
Offline
Kuski
User avatar

Joined: 5 Apr 2007, 12:30
Posts: 1157
Location: Norway, Sandnes
Exactly what I was thinkin about :D

_________________
TT:39.59.86|| AvgTT:41.49.24 || Multi TT:27:43:82 || Team [TR]


Top
 Profile  
 
 Post subject: Re: Kopasite Problem
PostPosted: 17 Aug 2015, 15:20 
Offline
Kuski
User avatar

Joined: 17 Aug 2002, 15:45
Posts: 1502
Location: on the roof
I think I have fixed that bug in my script, I can give you the code.

_________________
< roopemies> horror and frustrating and can't play, sounds just like you
Beer battle winner 2014 and 2015


Top
 Profile  
 
 Post subject: Re: Kopasite Problem
PostPosted: 17 Aug 2015, 15:50 
Offline
Kuski
User avatar

Joined: 13 Aug 2010, 20:31
Posts: 1007
Can you give it to jon too please? His elmastats site has exactly the same problem.


Top
 Profile  
 
 Post subject: Re: Kopasite Problem
PostPosted: 17 Aug 2015, 16:28 
Offline
Kuski
User avatar

Joined: 17 Aug 2002, 15:45
Posts: 1502
Location: on the roof
Yes it's actually very easy, you just need to use a floor function I think.

Code:
if ($time >= 0) {
   $i = floor($time * 62500 / 273);
   $outtime = sprintf("%01d:%02d,%02d", $i/6000, ($i/100)%60, $i%100);
}

_________________
< roopemies> horror and frustrating and can't play, sounds just like you
Beer battle winner 2014 and 2015


Top
 Profile  
 
 Post subject: Re: Kopasite Problem
PostPosted: 17 Aug 2015, 17:25 
Offline
Cheatless
User avatar

Joined: 19 May 2002, 17:05
Posts: 4239
to fix it, you need to replace that 62500 / 273 with 228.9377289377289 or whatever is the number stored in the elma.exe
it might look the same, but it isn't really, when the number is exact

_________________
[carebox]


Top
 Profile  
 
 Post subject: Re: Kopasite Problem
PostPosted: 18 Aug 2015, 10:36 
Offline
Kuski
User avatar

Joined: 17 Aug 2002, 15:45
Posts: 1502
Location: on the roof
That's good to know. But now would be also nicer to know what the exact number is for sure.

_________________
< roopemies> horror and frustrating and can't play, sounds just like you
Beer battle winner 2014 and 2015


Top
 Profile  
 
 Post subject: Re: Kopasite Problem
PostPosted: 18 Aug 2015, 13:57 
Offline
Kuski
User avatar

Joined: 14 Apr 2008, 17:58
Posts: 1458
Location: jkl
Yeps would be najs to get it fixed for sure, i have a few kopasite prs that can't be upped because of teh

_________________
Team MiE - MiE Cup 1
Prestigious member of 14.6x Tutor14 club


Top
 Profile  
 
 Post subject: Re: Kopasite Problem
PostPosted: 19 Aug 2015, 04:17 
Offline
Kuski
User avatar

Joined: 24 Nov 2009, 20:53
Posts: 807
Location: kristiansand, norway
static const double timefactor = 2.289377289377289681482352534658275544643402099609375;

_________________
Image


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 11 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group